1

(11 답글들, 버그 보고 및 QA (Quality Assurance)에 작성)

건더기 작성:

이상하네요...
저도 magic_quotes_gpc가 on인 것은 마찬가지입니다만......
저는 이런 현상이 전혀 없거든요...
DB상에서 직접 entries 항목을 보아도 \는 전혀 없고요...

저는 서버에 PHP 4.4.2와 MySQL 4.1.20으로 세팅해뒀습니다...
오란씨는 PHP는 4.4.4에 Mysql 4.1.12로 세팅되어 있네요...

제 phpinfo()는 http://kangjang.net/test.php 입니다...

테터 1.0.6.1은 이상없이 잘 돌아가는데... ㅠ.ㅠ
혹시 몰라 제가 테터 1.1 beta1 설치하는 과정을 상세히 적겠습니다. 잘못이 있다면 지적해 주세요.

* 테터 1.1 beta 다운로드 winzip10 으로 압축풀기
* Filezilla 2.2.27 실행, 계정 접속.
* 새폴더 생성(tt11b), 테터 1.1 파일 업로드 시작, 완료.
* tt11b 폴더권한 777 설정, skin 폴더권한 777 변경
* IE에서 /tt11b/setup.php 실행,
* 설치 과정중 테이블 구분자 "ttb_", 블로그 식별자 "tt11b"로 변경
* 에러 메시지 없이 단일블로그 설치완료.
* 블로그 접속, 새글작성,
* 내용에 "\" 삽입됨.

p.s) phpMyAdmin 처음 로그인 창에서 Language 가 euc-kr인 상태로
로그인하더라고 DB에 어떤 변화를 주는 건 아니죠??
바로 로그아웃에서 utf-8로 다시 로그인 했는데... 혹시나 해서요...

2

(11 답글들, 버그 보고 및 QA (Quality Assurance)에 작성)

gendoh 작성:

아무래도 DB 문제인 것으로 보고 있습니다.
MySQL 버전과 태터가 사용하는 테이블들의 케릭터 셋들을 알 수 있을까요?
혹시 동일한 문제가 발생하시는 분들은 이 부분좀 확인해 주셨으면 합니다.

DB에 대한 정보가 길어서 아래 링크로 적었습니다.

phpMyAdmin에서 DB정보를 복사한 겁니다.

http://exlove.oranc.co.kr/link/qna/exl_dbinfo.htm

답변 주시는데 참고가 되셨으면 합니다.

3

(11 답글들, 버그 보고 및 QA (Quality Assurance)에 작성)

저도 위에 님처럼 "\" 가 마구 삽입됩니다.

블로그 주소는 http://exlove.oranc.co.kr/tt11b/
PHPinfo는 http://exlove.oranc.co.kr/k_phpinfo/phpinfo.php 입니다.

"magic_quotes_gpc" 가 On 으로 되어 있길래

.htaccess 파일에 php_flag magic_quotes_gpc Off 삽입하고 FTP로 업로드, 덮어썼습니다.
--------------------------------------------------------------------------
<IfModule mod_url.c>
CheckURL Off
</IfModule>

php_flag magic_quotes_gpc Off

RewriteEngine On
RewriteBase /tt11b/
RewriteCond %{ENV:REDIRECT_SURI} !^$
RewriteRule (.*) - [L]
RewriteCond %{REQUEST_FILENAME} -d
.
.
.
--------------------------------------------------------------------------

그래도 문제해결이 안되네요... 제가 잘못한 부분있나요? 의견부탁드립니다.